1.15 Support

This update officially adds 1.15 Support. It is expected to work just fine but there may be bugs that would have to be reported.

Changes